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Introduction 1

What’s in this chapter
• Overview: page 1

• Assistance: page 3

• Supported devices: page 4 

• How to use this guide: page 6

• User safety: page 7

Overview   

Thank you for choosing Medtronic Diabetes as your partner in helping 

you and your patients better manage diabetes therapy. We believe 

you will benefit from CareLink™ Pro software’s leading edge 

technology and simple, menu-driven user interface.

This user guide describes how to use CareLink Pro to acquire, store 

and report patient treatment and diagnostic data. It also describes 

the option to access pump, meter, and sensor-based glucose data 

your patients have uploaded to CareLink™ Personal, a Web-based 

therapy management system that works with CareLink Pro.
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Features     

CareLink Pro is diabetes therapy management software for a personal 

computer (PC). It includes these features:

• Patient records can be created to store data gathered from a 

patient’s device as well as therapy data from their CareLink Personal 

account. 

• Data from insulin pumps, monitors, and blood glucose meters can be 

sent to the system, stored, and then used to generate reports.

• As an option, it interfaces with the CareLink Personal system, 

allowing access to device data patients have stored there. This is 

ideal for creating current reports between office visits, and may 

make the need to read device data during office visits unnecessary. 

• Different treatment reports can be created from device data stored 

in the patient’s record. Reports facilitate answers to therapy 

concerns such as patient adherence, patterns and exceptions.

• The system alerts you when software updates are available to be 

downloaded and installed. This ensures you have access to the latest 

features. 

• There is a Guide Me feature to help users who are new to CareLink 

Pro. It gives hints and tips about the tasks they are performing.

• An integrated help system is available throughout the software to 

provide information on specific areas of interest.

Security     

• CareLink Pro can be password protected.

• Transmission of patient data from CareLink Personal is encrypted 

using industry-standard Secure Sockets Layer (SSL) technology.

Related documents     

Each of these Medtronic MiniMed documents has device-specific 

information that is not covered in detail in this user guide. 

NOTE: For meters from
other companies, see

the instructions the
manufacturer included

with the meter.

• Paradigm Insulin Pump User Guide

• Guardian REAL-Time Monitor User Guide

• Sensor Features User Guide

• Paradigm Link Blood Glucose Monitor User Guide

• ComLink User Guide

• CareLink USB User Guide
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Assistance             

If you need further help with this system, contact one of the 

following resources. 

U.S. and Canada

Medtronic MiniMed provides a number to call for residents of the 

United States and Canada for guidance with software problems. The 

hours are Monday through Friday from 8:00 a.m. to 5:00 p.m. 
Pacific Standard Time.

Outside the U.S. and Canada

For assistance for residents of regions outside the United States or 

Canada, please contact your local country representative. Access the 

following URL for Medtronic’s international contact information:

http://www.minimed.com/help/contact/locations.html 

Department Telephone number

24 Hour HelpLine, if calling from within the 
United States and Canada

(800) 646-4633
800-MiniMed

24 Hour HelpLine if calling from outside the 
United States and Canada 818-576-5555

MiniMed Web site www.minimed.com
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NOTE: Some devices
supported by this

software may not be
available in all

countries where this
software is approved

for use.

Supported devices      

CareLink Pro gets data from the following devices.           

Insulin pumps/Glucose monitors    

Medtronic MiniMed pumps 508

MiniMed Paradigm pumps 511, 512, 712, 515 and 715

Paradigm REAL-Time System

522 and 722
522K and 722K
523 and 723
523K and 723K
553 and 753

Guardian REAL-Time monitor CSS-7100
CSS-7100K

Manufacturer Blood glucose meters     

Medtronic/BD:
• Paradigm Link™ Blood Glucose Monitor 
• BD Logic™

LifeScan:

• OneTouch® UltraSmart®

• OneTouch® Profile® 

• OneTouch® Ultra® 

• OneTouch® Basic® 

• OneTouch® FastTake® 

• OneTouch® SureStep®

• OneTouch® Ultra®2

• OneTouch® UltraLink™

Bayer:

• Ascensia® BREEZE®

• Ascensia® CONTOUR®

• Bayer CONTOUR® LINK

Bayer Ascensia® DEX® family, 
including these compatible 
meters:

• Ascensia® DEX® 

• Ascensia® DEX® 2 

• Ascensia® DEXTER-Z® II

• Glucometer® DEXTER-Z®

• Ascensia® ESPRIT® 2 

• Glucometer® ESPRIT®

• Glucometer® ESPRIT® 2

Bayer Ascensia ELITE™ 
family, including these 
compatible meters:

• Ascensia ® ELITE® 

• Ascensia ® ELITE® XL 



CareLink Pro™ User Guide    Introduction      5

Equivalent devices       

When you add a device to the system, you select its make and model 

from a list. If a device make and model is not on the list, refer to the 

following table to find an equivalent one to use.

Abbott

• Precision Xtra™ 

• Abbott FreeStyle®, FreeStyle Flash™
• FreeStyle Papillion™ Mini 
• FreeStyle Mini™ 
• Optium Xceed™
• Precision Xceed™

Roche

• Accu-Chek® Aviva

• Accu-Chek® CompactPlus

• Accu-Chek® Compact

• Accu-Chek® Active

Communication devices                 

 Com-Station
for use with the Medtronic MiniMed 508 
Pump. (See the Com-Station User Guide 
for details about the required hardware.)

ComLink
for use with the MiniMed Paradigm Pump. 
(See the ComLink User Guide for details 
about the required hardware.) 

Paradigm Link™ Blood Glucose 
Monitor

for use with a MiniMed Paradigm Pump. 
(See the Paradigm Link Blood Glucose 
Monitor User Guide for details about the 
required hardware.)

CareLink® USB
for use with a MiniMed Paradigm-series 
insulin pump.

Data communications cable
for use with third-party blood glucose 
meters. Each meter manufacturer 
supplies a data communications cable.

Manufacturer Blood glucose meters     

If your patient uses one of these devices Select this device

• Bayer Ascensia® DEX® 2

• Bayer Ascensia® DEX® 

• Bayer Ascensia® DEXTER-Z®

• Bayer Glucometer® DEXTER-Z®

• Bayer Ascensia® ESPRIT® 2 

• Bayer Glucometer® ESPRIT®

• Bayer Glucometer® ESPRIT® 2

The Bayer Ascensia® DEX® 
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NOTE: Meters can be
ordered from their

respective companies.

Ordering                             

Contact one of the following to order Medtronic MiniMed products:

U.S. and Canadian residents

• Within the U.S. and Canada: call 1-800-646-4633 (1-800-MiniMed)

• Outside the U.S. and Canada: call +1-818-362-5958

Non-residents of the U.S. or Canada

• Contact your local country representative.

How to use this guide   

NOTE: This user guide
shows samples of the

software screens. The
screens of the actual

software may be
slightly different.

Refer to the Glossary for definitions of terms and functions. The 

conventions used in this guide are defined in the following table.

Bayer Glucometer ELITE® XL The Bayer Ascensia ELITE™ XL 

If your patient uses one of these devices Select this device

Term/style Meaning

Click press the left mouse button over an object on the 
screen to select it 

Double-click press the left mouse button twice over an object on the 
screen to open it

Right-click press the right mouse button over an object on the 
screen to display another window or menu

Bold text
used for a menu option or menu path. For example: 
Patient > New Patient

UPPER CASE text indicates a button. For example: SAVE

Italicized text used for screen and field names. For example: Reports 
screen

Indented shows paths to files or directories. For example:

C:\Program Files\MM CareLink Pro

NOTE: additional information

CAUTION: warns of a hazard which, if not avoided, may result in 
minor or moderate injury to the software program or 
equipment.

WARNING: notifies you of a potential hazard which, if not avoided, 
could result in death or a serious injury. It may also 
describe potential serious adverse reactions and safety 
hazards.
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User safety         

Indications for use 

The CareLink Pro system is intended for use as a tool to help manage 

diabetes. The purpose of this system is to take information 

transmitted from insulin pumps, glucose meters and continuous 

glucose monitoring systems, and turn it into CareLink Pro reports. The 

reports provide information that can be used to identify trends and 

track daily activities—such as carbohydrates consumed, meal times, 

insulin delivery, and glucose readings. 

Warnings 

• This system is intended to be used by a healthcare professional 

familiar with the management of diabetes. 

• System results are not intended to produce medical advice and should 

not be relied upon for such purpose. 

• This product should only be used with the supported devices listed in 

this document. (See Supported devices, on page 4.)

• Patients should be advised to monitor their blood glucose levels at 

least 4 -6 times a day.

• Patients should be advised not to make any changes to their 

treatment without consulting their healthcare professional.

• Patients should be advised to make treatment decisions based on 

healthcare professional guidelines and meter BG results, not glucose 

sensor results.

Contraindications 

This software should not be used with devices that are not listed in 

Supported devices, on page 4. Nor should this product be used for the 

treatment of medical conditions other than diabetes.

Before opening this software, close any of the following software that 

is currently running on your computer:

• CGMS® System Solutions™ Software 

• Solutions® Pumps & Meters Software 

• Guardian® Solutions® Software 

• ParadigmPAL™ 

• CareLink™ Personal 

• Solutions® Software for CGMS® iPro
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Navigating the system 2

What’s in this chapter
• Overview: page 8

• Opening CareLink Pro: page 8

• Workspaces: page 10

• Main Menu bar: page 12

• Toolbar: page 12

• The Guide Me feature: page 13

• Learn More links: page 14

• Help system: page 14

Overview

Use this chapter to familiarize yourself with the CareLink™ Pro 

graphical user interface (GUI). The user interface includes menus, a 

toolbar, a navigation bar, workspaces, and a Guide Me window. 

Opening CareLink Pro                  

1 Double-click the CareLink Pro icon on your computer desktop.

If your clinic requires you to enter a password, the login screen is 

displayed.

 CareLink Pro
desktop icon
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a. Type your password into the Password field. 

NOTE: Requiring a
password is an optional

feature that is set
during the installation

process.

b. Click LOGIN.

The startup screen is displayed.

2 To start a new patient record, click NEW PATIENT. To open a patient 

record from a list of patients in the system, click OPEN PATIENT.

NOTE:If you see a
message that the

system is unavailable,
it means a database

backup or restore is in
progress. See When the

system is unavailable, on
page 61 for more

information.

        

main menus

active 
workspace

access patient listadd new patient

navigation bar

status bar

Reports
workspace button

Devices
workspace button

Profile
workspace button

display/hide the Guide Me 
window
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Workspaces     

NOTE: See the other
chapters of this user

guide for details about
the workspaces and

how to use them.

If you have a patient’s record open, you can click one of the buttons 

on the navigation bar to display the corresponding workspace. Use 

these workspaces to enter or select information to perform CareLink 

Pro tasks for that patient.

• Profile: Allows you to maintain such patient information stored as 

name and date of birth. This workspace also allows you to link to a 

patient’s CareLink Personal.

• Devices: Allows you to store information required to read a patient’s 

devices.

• Reports: Allows you to select parameters and choose reports to be 

generated for the patient.

Until a profile is added and saved for a patient, only the Profile 

workspace is accessible for that patient. Until devices are added for a 

patient, only the Profile and Devices workspaces are accessible for 

that patient.
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Workspaces

Devices workspace

Profile workspace

Reports workspace

Profile

Devices

Reports
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Main Menu bar       

The following shows the options available through the main menu. 

Some of these menu options can also be accessed using the keyboard 

shortcut listed next to the menu option (e.g., Ctrl+N for New 

Patient). You can also use the navigation bar or the toolbar to access 

some menu options.

Toolbar     

The CareLink Pro toolbar provides quick access to frequently used 

features. The toolbar contains the following buttons.

Button Name Functionality

 Add Patient Opens a Profile workspace so you can add 
a new patient record to the system.

Open Patient
Opens the Patient Lookup table where you 
can choose an existing patient’s record to 
view.

Guide Me Displays or hides the Guide Me window. 
Click for context-aware system hints. 
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Patient tabs

Once you open a patient record, a tab is displayed along the toolbar 

with the patient’s name on it. When a tab is active, it means that 

patient record and workspace are active, and you can perform 

CareLink Pro tasks for the patient.

A patient’s record can be made active simply by clicking on their 

patient tab. To close their record, click the CLOSE button on their 

tab.

The Guide Me feature     

A Guide Me feature is provided throughout CareLink Pro. It opens a 

window with context-aware hints and tips for actions you might take 

from the part of system that is active. Guide Me windows might also 

include >>learn more links. When clicked, these links take you to the 

relevant section in the online help for more details. The Guide Me 

feature is enabled by default. However, you can turn it off at any 

time.

CLOSE 
button 

inactive tab active tab

Close button
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Turning Guide Me on and off      
Button option

• Click the GUIDE ME button to either turn Guide Me on or off.

Menu option

• Select Help > Guide Me to select or deselect the feature.

Learn More links     

Learn More links take you to a related topic in the online help system. 

They are provided throughout the system, within Guide Me windows 

or the software. Click >> learn more if you are unsure how to proceed 

or what values to enter. 

Help system     

The help system is available to assist you as you use CareLink Pro. It 

provides information about how to perform tasks in the software. 

To access the help system, do one of the following:

• Select Help > CareLink Pro Help. 

• Press the F1 button.

Guide Me button

learn more link
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Getting Started 3

What’s in this chapter
• Before you begin: page 15

• Opening and closing patient records: page 17

• Setting system preferences: page 18 

This chapter guides you through starting the CareLink™ Pro 

software, opening and closing patient records, and setting 

preferences that apply to all patients in the system. 

Before you begin

If this is the first time you are using CareLink Pro, you should be 

sure to set the General preferences (see General preferences, on 

page 18). These preferences determine how certain items display 

in the software and in reports, and how you want the system to 

communicate with the Internet.

Preferences can be set at any time. You may want to wait until 

you are familiar with the CareLink Pro software to set the other 

preferences.
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Primary system tasks      

The following table outlines the main tasks you will want to perform 

when first setting up and using CareLink Pro. It also tells you which 

part of this user guide discusses each task.

Step Location

Familiarize yourself with the CareLink 
Pro GUI. Chapter 2, Navigating the system

Define the global system options your 
clinic will use.

Setting system preferences, on 
page 18

Create profiles for each of your 
patients. Adding new profiles, on page 25

Link to your patients' CareLink Personal 
accounts.

Linking to CareLink Personal 
(optional), on page 27

Add your patient's pump and meters to 
their profile. Adding a device, on page 37

Read data from your patient's pump and 
meters. Reading device data, on page 44

Set up and generate reports for each of 
your patients.

Creating reports, on page 47

Regularly back up the CareLink Pro 
database.

Backing up a database, on page 59

Update the CareLink Pro software. Applying software updates, on page 58
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Opening and closing patient records

Opening patient records         

As many as six patient records can be open at one time. If you have 

not yet created any patient profiles, see Adding new profiles, on 

page 25.

1 Select File > Open Patient, or click the OPEN PATIENT button. A 

patient list similar to the following is displayed.

NOTE: If you receive a
message that you have

too many patient
records open, click OK,

close a record, and
continue.

2 Locate the patient’s listing by typing some or all of their name in the 

Find a Patient field. When the patient’s listing is highlighted, click 

OPEN, double-click the listing, or press ENTER. You can also navigate 

the list by using the up and down arrows on your keyboard. 

The patient’s Devices (if devices have not yet been added) or 

Reports workspace is displayed.

3 To see the patient’s Profile workspace, click the PROFILE button on 

the navigation bar.

Closing patient records        

1 Make sure the patient record you want to close is active (the tab is 

highlighted).

2 Do one of the following:

a. Select File > Close Patient.

b. Click the CLOSE button on the patient tab.

c. Press Ctrl-F4.

Open Patient
button

Profile button

close button
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Setting system preferences             

These preferences apply to all patients in the system. For preferences 

that affect only individual patients, see Verifying report settings, on 

page 51.

Preferences are displayed in the following groups:

• General

– Glucose units

– Carbohydrate units

– Communications

– Troubleshooting
• Patient Profile

– Select and arrange data fields on patient profiles.
• Patient Lookup

– Modify and change the order of fields displayed when you choose 
Open Patient to view a list of patients.

• Report Generation

– Choose the data fields you want to display when selecting Daily 
Detail report input from the Data table.

General preferences           
1 Select Tools > Options. The following window is displayed.

2 Click to select the option button for the value you want:
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– Glucose Units: mg/dL or mmol/L

– Carbohydrate Units: grams or Exchanges

a. If you selected Exchanges for Carbohydrate Units, type the 
appropriate number in the grams are equal to 1 Exchange field.

3 For the following Communications, click to select the check box 

(enable), or to clear the check box (disable):

NOTE: Make sure you
follow the guidelines of

your clinic or IT
department when

setting communication
preferences.

– Automatically check for software updates: if selected, a 
notification will be sent to each system running CareLink Pro 
whenever a software update is available. The active user will 
then have the opportunity to download and install the updates. 
To prevent this from occurring and institute a controlled 

distribution of software updates, you can clear this check box. 

– Synchronize with CareLink™ Personal: If you want the system to 
automatically synchronize your patients' CareLink Personal data 
each time you open their profile, select the Synchronize with 
CareLink Personal check box. If you clear this check box, you will 
have to manually synchronize the CareLink Personal data for each 
patient.

4 Click to select or clear the check box in the Troubleshooting section. 

If the check box is selected, the application will save a record of 

device reads for troubleshooting purposes.

5 Click OK to save the General preferences. 
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Patient profile preferences         

1 Select Tools> Options. 

2 Click the Patient Profile tab. The following window is displayed.

Choosing data fields        
1 Use the check boxes to add the fields you want.

NOTE: First and Last
Name cannot be

removed.

2 To remove a field from the profile, clear its check box.

3 To make a field required, select the check box in the Required 

column. Any field that is required must be filled in before a profile 

can be created.

Adding a custom field         

1 Select the check box to the left of an empty custom field.

2 Enter text to name the field (e.g., Emergency Contact). This is the 

field name that will display on the patient profile.

3 To make the field required, select the check box in the Required 

column.

Use the check boxes to choose the fields you want on the profile. Use the up and down 
arrows to put the fields in order.
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NOTE: To remove a
custom field from the

profile, clear the check
box next to the field(s)

you want to remove.

Changing the order of data fields         

• Select the field you want to move, and click the up or down arrow to 

move it. (The arrows at the top and bottom move a field all the way 

to the top or bottom of the list.) 

Finalizing patient profile preferences

• When the Field Order list has all the fields you want in the correct 

order, click OK.

Patient profiles now have the fields and field order you just 

selected.

Patient Lookup preferences         

1 Select Tools> Options. 

2 Click the Patient Lookup tab. The following window is displayed.

Choosing data to display        
• Use the check boxes to select the type of data you want to display, 

or to clear data you do not want to display on the Patient Lookup 

table.

Up & Down
 arrows

Use the check boxes to choose the data you want on the Patient Lookup table. Use the 
up and down arrows to put the columns in order.
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NOTE: First and Last
Name cannot be

removed.

Changing the column order         
• To change the order of columns on the Patient Lookup table, select 

the column to move, and click the up or down arrows. (The arrows at 

the top and bottom move a data column all the way to the top or 

bottom of the list.)

NOTE: The data column
at the top of the Column

Display Order list will
display in the first

column of the Patient
Lookup table. The data

column at the bottom
will be displayed in the

last column of the
table.

Finalizing patient lookup preferences

• When the Column Display Order list has all the data you want in the 

correct order, click OK.

The Patient Lookup table will now have the data and column order 

you just selected.

Report Generation preferences         
The Data Table is displayed during the selection portion of the report 

generation process. This table should include data the healthcare 

professional finds most useful in deciding the dates for which they 

want to see Daily Detail reports.

NOTE: To see how these
preferences apply to

the Data Table during
report creation, see

Selecting report types
and inclusion dates, on

page 52.

1 Select Tools> Options. 

2 Click the Report Generation tab. The following window is displayed.

Up & Down
 arrows

Use the check boxes to choose the type of data you want on the Data Table. Use the up 
and down arrows to put the columns in order.
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Choosing data to display        

• Use the check boxes to select the type of data you want to display or 

clear data you do not want to display on the Data Table.

Changing the column order         

• To change the order of columns on the Data Table, select the column 

to move, and click the up or down arrow. (The top and bottom arrows 

move a data column all the way to the top or bottom of the list.)

NOTE: Items at the top
of the Column Order list
will display in the first

column of the Data
Table. Items at the

bottom will be
displayed in the last

column of the Data
Table.

Finalizing report generation preferences

• When the Column Order list has all the data you want in the correct 

order, click OK. 

The Data Table will now have the data and column order you just 

selected.

Up & Down
 arrows
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Profile workspace 4

What’s in this chapter
• Before you begin: page 24

• Adding new profiles: page 25

• Editing patient profiles: page 25

• Deleting patient data from the system: page 25

• Linking to CareLink Personal (optional): page 27

A profile is similar to the cover page of a medical chart. It stores 

patient data such as name and date of birth. A profile is required 

before device data can be gathered and used for therapy reports.

The Profile workspace also allows you set up a link to a patient’s 

CareLink Personal account. Once the link is established, you can 

retrieve patient data stored on CareLink Personal anytime—without 

the need to have the patient present.

Before you begin

You may want to customize your patient profiles so they contain only 

the type of information you want to collect. To learn more, see 

Patient profile preferences, on page 20.

Also, a username and password is required when you set up the link to 

a patient’s CareLink Personal account. The patient must be present to 

supply this data.
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Adding new profiles        

Each time you add a patient to the CareLink Pro system, you must 

start by filling out a profile for them. 

1 Select File > New Patient, or click the ADD PATIENT button. 

The Profile workspace is displayed (see the example on page 11). 

NOTE:To add or change
fields on the patient

profile, click
>>customize fields. See

Patient profile
preferences, on page 20.

2 Fill in the fields in the Patient Profile section. 

3 Click SAVE.

The new patient profile is added to the CareLink Pro database. A 

message is displayed that confirms the profile was saved.

Completing required fields

1 If a required field is not complete when you save a patient profile, a 

message is displayed next to that field. You will not be allowed to 

save the profile until you make an entry in the field.

2 Complete the field.

3 Click SAVE.

4 When the confirmation message displays, click OK.

Editing patient profiles        

1 Make sure the patient’s Profile workspace is open.

2 Click EDIT.

3 Edit the data in the Patient Profile section as needed.

4 Click SAVE.

A message is displayed that confirms the profile was saved.

Deleting patient data from the system        

1 Make sure the patient’s Profile workspace is open. 

2 Verify that this is the patient you want to delete. Deleting a patient 

profile also removes all of their data from the CareLink Pro database 

and cannot be undone.

3 Click >> delete patient record above the synchronization section of 

the profile.

A message is displayed to alert you that all of the patient’s data will 

be erased when you delete the record. 

Add Patient
button
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4 Click YES to delete the patient’s record.
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Linking to CareLink Personal (optional)         

If your patient permits it, you can set up a link to their CareLink 

Personal account. This Web-based tool allows patients to upload and 

store device-derived data, and to run various therapy reports. 

Once you link to the patient’s CareLink Personal account, you can 

retrieve the device data they store there. This is ideal for creating 

CareLink Pro therapy reports between office visits. It also reduces the 

need to read the patient’s device in the office.

If a patient does not yet have a CareLink Personal account, you can 

send them an e-mail inviting them to establish one. 

Linking to an existing account             
NOTE: The patient must
be present to complete

these steps.

1 Make sure you are connected to the Internet.

2 Open the patient’s Profile workspace. 

3 Make sure all required fields in the Patient Profile section are filled 

in.

4 Click LINK TO EXISTING ACCOUNT. 

The CareLink Personal Log In screen is displayed.

5 Have the patient do the following:

a. Type in their Username and Password.

b. Click SIGN IN. 

A Grant of Access page is displayed, based on the patient’s 

enrollment settings for language and region.
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6 Have the patient do the following:

a. Read the Terms of Use.

b. Click to check the box next to I agree to the Terms of Use 
above... 

c. Click GRANT ACCESS.

d. Let you know when the Thank You page is displayed.
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You can print the Terms of Use for the patient by clicking the PRINT 

button.

You are now linked to this patient’s CareLink Personal account. See 

Getting data from a linked account, on page 30.

Sending an e-mail invitation            

To send an e-mail inviting a patient to establish a CareLink Personal 

account, follow these steps:

1 Open the patient’s Profile workspace. 

2 Make sure all required fields in the Patient Profile section are filled 

in.

3 Click SEND E-MAIL INVITATION TO PATIENT.

4 Make sure Patient Name, Email and Language... are filled in 

correctly.

5 Click SEND. 

The patient’s profile status area confirms the e-mail was sent.

Unlinking a patient’s CareLink Personal account from CareLink Pro

You can unlink a patient’s CareLink Personal account from CareLink 

Pro. This option is only available after a patient has been linked. It 

prevents CareLink Pro from continuing to retrieve data from the 

patient's CareLink Personal account. It does not affect the patient's 

personal usage of their CareLink Personal account.

1 Open the patient's record and access the Profile workspace.
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2 Click UNLINK ACCOUNT.

3 Click Yes at the confirmation message. The patient's personal profile 

is no longer linked to CareLink Pro.

The status is changed to "Not linked," and the LINK TO EXISTING 

ACCOUNT and SEND E-MAIL INVITATION TO PATIENT buttons are now 

displayed.

Getting data from a linked account            

If you are linked to a patient’s CareLink Personal account, any new 

data from this account is automatically sent each time you open their 

patient profile in CareLink Pro. 

NOTE: To ensure this
happens, go to Tools >
Options > General, and

make sure there is a
check next to

“Synchronize with
CareLink Personal.”

Follow these steps to get a patient’s CareLink Personal data any time 

after you have opened their patient profile:

1 Make sure the patient’s Profile workspace is open, and that you are 

connected to the Internet.

2 Select Tools > Synchronize Patient Data.

The sync icon on the patient’s tab rotates. When the icon stops, the 

process is complete.

NOTE: If the patient no
longer wants to

share their CareLink
Personal data, a

message displays to let
you know.

3 Any additional data retrieved from CareLink Personal will show up in 

the patient’s reports. 

sync icon
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Hardware setup 5

What’s in this chapter
• Before you begin: page 31

• Connecting devices: page 32

This chapter provides diagrams that show how to set up a 

patient’s device so your computer can read data from it.

You have to have the patient’s device in order to read data 

directly from it. However, you can get device data from a 

patient’s CareLink™ Personal account, without reading it from 

their device.   

Before you begin

To read data directly from a device, you must have the patient’s 

device. You must also have any cables or other communication 

devices you need to send device data to your computer.
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Connecting devices             

NOTE: For more details,
follow the instructions

CareLink™ Pro displays
as you are reading

devices.

Review the overview diagram to get a general idea of how devices 

should be set up to communicate with the computer. The diagrams 

that follow illustrate specific aspects of device communication. 

NOTE: This example
shows the ComLink

being used to
communicate between

the pump and the
computer.

Overview of hardware setup               

TM

CareLinkUSB

CareLink USB

PC

Paradigm Pump
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Hardware connection diagrams                                    

                           

PC Connections

USB
port

Serial
port
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connect to serial
port on PC

ComLink for use with the Paradigm series pump

Optional components

Com-Station for use with MiniMed 508 pumps and for meter pass-through
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NOTE: The picture
above shows a few

examples of the many
supported meters.

Connect to 
serial port on

your computer

9-pin 
serial adapter

Meter options

Bayer CONTOUR® LINK

Connect to
USB port on

your computer

OK

LifeScan OneTouch® 
UltraLink™

M

UltraLink
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Devices workspace 6

What’s in this chapter
• Before you begin: page 37

• Adding a device: page 37

• Making a device active or inactive: page 42 

• Reading device data: page 44

Information you need to read a patient’s device (make, model, 

serial number, etc.) is stored in the The Devices workspace. Thus, 

you do not have to supply it each time you read data from the 

device. 

Devices on the Devices workspace are stored in one of two lists—

Active Devices or Inactive Devices. When you add a device, it is 

automatically placed on the Active Devices list. You can only read 

data from devices displayed in the Active Devices list. These will 

likely be the devices your patient currently uses. 

Other devices that belong to the patient, but are not currently 

used, can be stored in the Inactive Devices list. This keeps the 

information on file. These devices can be made active at any time.



CareLink Pro™ User Guide    Devices workspace      37

Before you begin

Before you can open the Devices workspace for a patient, they must 

have a profile saved in the system. See Chapter 4, Profile workspace.

To add a device or read data directly from it, the device must be in 

communication with the computer. See Chapter 5, Hardware setup to 

learn how to set up devices to communicate with the computer.

Adding a device         

To add a device to a patient’s record, you must have the device in 

communication with the computer so the connection can be tested.

You can get data from the patient’s CareLink Personal account for a 

device not yet added. Such devices will automatically be added when 

data is synchronized between CareLink Personal and CareLink Pro.

NOTE: There can only
be one active pump per

patient. Adding a new
pump will move the
existing one to the

inactive list.

Adding a Medtronic pump or Guardian monitor          

1 Make sure the pump you are adding is set up to communicate with 

the computer. (See Chapter 5, Hardware setup for connection 

steps.)

2 Click the patient’s tab. Or double-click their name on the Patient 

Lookup table.

3 Click DEVICES to access the patient’s Devices workspace (see the 

example on page 11).

4 Click ADD DEVICE.

5 Select Medtronic Pump/Guardian. The Add Medtronic 

Pump/Guardian Wizard is displayed.

DEVICES button
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NOTE: The pump model
is listed on the back of

the pump or on the
pump status screen.

6 Select the option button to specify the device you are adding. 

If you selected the MiniMed 508 pump option, go to Step 9.

7 Click NEXT. The Serial Number page is displayed.

NOTE: An error message
is displayed if you do
not enter the correct
serial number. Check
the examples on this

page, and verify that
you are entering the

correct characters from
the back of the pump. If

necessary, re-type the
six characters.

8 Use the examples on this page to help locate the six-character serial 

number on the device you are adding. (If you need more help in 

locating it, click >>learn more.) Type the six characters in the 

Device Serial Number field.

9 Click NEXT. A Communication Options page similar to the following is 

displayed.

10 Click the Choose Port arrow, and select the port that the ComLink, 

Paradigm Link, CareLink USB, or Com-Station connects to on your 

computer. If you are not sure which port to choose, select Auto 
Detect (or USB). 
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11 Click NEXT. The Test Connection page similar to the following is 

displayed.

12 Follow any device instructions, and click TEST.

A message displays to let you know if the connection was successful. 

If it was, go to the next step. 

NOTE: This Test does
not read pump data,
but verifies correct

communications
between the pump and

the computer.

If not, make sure the hardware between the device and the 

computer is connected properly. Also, click BACK on the pages of the 

wizard to make sure the device data you have entered is correct.

13 Click DONE.

The pump is added to the patient’s Active Devices list.
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Adding a meter            

1 Click the patient’s tab. Or double-click their name on the Patient 

Lookup table.

2 Make sure the meter you are adding is in communication with the 

computer. (See Chapter 5, Hardware setup for connection steps.)

3 Click DEVICES to access the patient’s Devices workspace (see the 

example on page 11).

4 Click the ADD DEVICE button.

5 Select Blood Glucose Meter. The Add Blood Glucose Meter Wizard is 

displayed.

6 Click the option button to select the correct brand of meter.

7 Click NEXT. The Meter Model page is displayed (this page differs 

depending on the meter manufacturer).

8 Click to select the meter model you are adding. 
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9 Click NEXT. The Communication Options page is displayed.

NOTE: Only those
choices that are valid
for the meter you are

adding are available for
selection.

10 Click the Choose Port arrow, and select the port that the ComLink, 

Paradigm Link, or CareLink USB connects to on your computer. If you 

are not sure which port to choose, select Auto Detect (or USB). 

11 Click NEXT. The Test Connection page is displayed.

12 Follow the instructions given for the meter, and click TEST.

A message displays to let you know if the connection was successful. 

If it was, go to the next step. 

If not, make sure the hardware between the device and the 

computer is connected properly. Also, click BACK on the wizard to 

make sure the data you have entered is correct.

13 Click DONE.

The meter is added to the patient’s Active Devices list.



CareLink Pro™ User Guide    Devices workspace      42

Making a device active or inactive      

Patient devices can be moved between the Active Devices list and the 

Inactive Devices list as needed. A device must be active in order to 

read data from it. 

You can have as many meters as you want on the Active Devices list, 

but only one pump. Make sure you want to inactivate the current 

active pump before you add a new one.

Inactivating a device               
1 Click the patient’s tab. Or double-click their name on the Patient 

Lookup table.

2 Click DEVICES to access the patient’s Devices workspace.

NOTE: Devices may be
listed under an

equivalent device
name. See Equivalent

devices, on page 5.

3 Click >> make this device inactive under the device you want to 

make inactive.

The device moves to the Inactive Devices list.

Re-activating a device                
1 Click the patient’s tab. Or double-click their name on the Patient 

Lookup table.

2 Click DEVICES. The patient’s Devices workspace is displayed.

NOTE: Devices may be
listed under an

equivalent device
name. See Equivalent

devices, on page 5.

3 Click >> activate this device under the device you want to make 

active.

The device moves to the Active Devices list.

Deleting a device               
These steps will delete a device and its data from the Devices 

workspace and the CareLink Pro system:

1 Click the patient’s tab. Or double-click their name on the Patient 

Lookup table.

2 Click DEVICES to access the patient’s Devices workspace.

NOTE: Devices may be
listed under an

equivalent device
name. See Equivalent

devices, on page 5.

3 Make sure the device is on the Inactive Devices list. If it is not, click 

>> Inactivate this device under its current listing.

4 Click >> delete this device under the device you want to delete.
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A message is displayed to alert you that the device and all of its data 

will be removed from the patient’s record.

5 Click YES to delete the device. 

The device and its data is removed from the Devices workspace and 

from the CareLink Pro system. Data from this device is no longer 

available for use in reports.
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Reading device data            

One way to get device data is to link to the patient’s existing 

CareLink Personal account. (See Linking to CareLink Personal 

(optional), on page 27.) Another way is to read it directly from their 

device, as described in this chapter. 

Data from your patient’s device can be read by CareLink Pro if the 

device is on the Active Devices list and it is in communication with 

the computer. Once you get this data, you can use it to create reports 

that help assess the patient’s therapy management. (See Chapter 7, 

Reports workspace to learn more about reports.)

CareLink Pro can also gather data from your insulin pump including:

• Various settings on the pump, such as the alert mode, the beep 

volume and the time display

• Basal insulin amounts delivered

• Bolus insulin types and amounts delivered

• Bolus Wizard entries

• Priming amounts

• Suspend periods

• Sensor glucose readings over a period of time

The system gathers blood glucose data from your glucose meter 

during a device read.

WARNING: Please cancel or finish any temp basals or active boluses, and clear any active 
alarms. The pump will be suspended for reading. Once the read is complete, please verify 
the pump has resumed.

CAUTION: Do not use the pump remote when the pump is being read. 

If the pump battery is low, the pump will not send data to the PC. Replace the battery if 
the status indicates battery power is low.    
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1 Click the patient’s tab. Or double-click their name on the Patient 

Lookup table.

2 Make sure the patient’s device is in communication with the 

computer. (See Chapter 5, Hardware setup.)

3 Click DEVICES to access the patient’s Devices workspace.

NOTE: Devices may be
listed under an

equivalent device
name. See Equivalent

devices, on page 5.

4 Find the device you want to get data from on the Active Devices list, 

and make sure the Choose port data is correct.

– For pumps click the Amount of Data arrow and select how much 
pump data you want CareLink Pro to read.

5 Click the associated READ DEVICE button.

6 Follow device-specific instructions, and click OK.

7 CareLink Pro displays a progress bar that updates to show how much 

of the device read has been completed.

If you click CANCEL as the device is being read, a message is 

displayed to alert you that cancelling the action may result in the 

loss of all of the data read so far.

– To cancel, click YES. 

– To continue reading device data, click NO.

When the system finishes reading data from the device, you will see 

a message that confirms the device read is complete.

8 Click OK. 

– For pumps, follow the instructions for taking it out of suspend 
mode.

If CareLink Pro is unable to get data from the device, see Chapter 9, 

Troubleshooting for further guidance.
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Reports workspace 7

What’s in this chapter
• Before you begin: page 46

• Creating reports: page 47

• About reports: page 54

• Exporting data: page 55

The CareLink™ Pro Reports workspace allows you to transform device-

derived data into clinically useful information. For the report types 

you can create see About reports, on page 54. 

Reports can be generated on screen, sent directly to a printer, or 

saved as TIFF or PDF files that you can attach to an Electronic Medical 

Record (EMR). You can generate several report types through a single 

operation.

The data displayed through these reports is captured from the 

patient’s devices, from their CareLink Personal account, or from 

both. 

Before you begin

If you have a period of time you want reflected in a report, you must 

have a patient’s device data for that time period. You may also need 

to have the patient’s device connected to the computer to get 

current data before running reports.

Be sure to take a close look at the Verify Report Settings step before 

running a report. This is where you can fine tune a report to capture 

the patient data you want.
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Creating reports       

The following sections describe the steps involved in creating one or 

more reports.

Opening the Reports workspace      

1 Click the patient’s tab. Or, click the OPEN PATIENT button and 

double-click their name.

The Reports workspace is displayed (see the example on  page 11).

NOTE: To make sure you
have the latest device

data from the patient’s
CareLink Personal

account, click SYNC
DATA.

Selecting the reporting period        

1 To change how much time is reflected in the report(s), click the 

Duration arrow and select the amount of time. (The maximum 

duration is 12 weeks.)

2 From and through dates are automatically set, unless you choose the 

custom date range option. 

NOTE: If you select a
date range longer than

allowed, you get an
error message. Adjust
the duration or dates.

If you want a custom date range, click the From or Through drop-

down arrows and select the desired month, date or year. 

Data calendar

The data calendar area of the Reports workspace shows a three-

month window of reporting information. It lists devices, and it shows 

how much device data is contained in the selected three months. It 

also shows the duration of the reporting period for the selected 

three months. 

Overlap in the device data and reporting period means you have data 

for some or all of the displayed reporting period.

Open Patient
button

device data
reporting period

data calendar
months
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The data calendar area initially displays the most current three 

months. To see other months, click the arrow buttons on either end 

of the months.

Selecting source data to include       

1 If the patient uses a BG meter that links to their pump, click to 

choose one of the following options for reporting meter BG data: 

– in the pump: Advantages of this selection include that you only 
have to read data from the patient’s pump, BG readings are time 
stamped by the pump, and the readings are tied directly to any 
Bolus Wizard calculations used. A disadvantage is that if there are 
communication difficulties between the pump and the linked 
meter, BG readings during that time may not get reported. Also, 
for MiniMed Paradigm pumps prior to the 522/722, any BG 
readings from Bolus Wizard calculations that are not acted on do 
not get reported.

– in the link meter(s): The advantage of this selection is that all 
readings stored in the linked meter are reported. The 
disadvantage is that to correlate meter and pump data, you must 
have made sure that the pump and meter clocks were 
synchronized with one another. You must also read data from the 
pump and the linked meter separately.

2 To add device data to reports, select the check box next to the 

relevant device. 

You cannot add devices that were excluded due to your selection in 

step 1. To change this, select the other linked meter option.

3 To exclude device data from reports, clear the check box next to the 

relevant device. 

You cannot clear check marks related to the option you selected in 

step 1. To change these, select the other linked meter option.

Overlap between the device data and 
reporting period

arrow buttons
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Checking for device data        

1 Look at the data calendar area of the Reports workspace to see if 

the reporting period overlaps with the device data (see the example 

on page 48).

2 If the bars overlap for the entire reporting period, you have data for 

your report(s). You can click NEXT and go to Verifying report 

settings, on page 51.

3 If the bars do not overlap, or there is not enough overlap, you have a 

few choices:

– Adjust the reporting period (see Selecting the reporting period, 
on page 47).

– Get additional device data (see Getting additional device data 
(optional), on page 49).

Getting additional device data (optional)        

1 To get more data from a device, click the READ DEVICE button 

associated with the device.

The Read Device bar is displayed.

WARNING: Please cancel or finish any temp basals or active boluses, and clear any active 
alarms. The pump will be suspended for reading. Once the read is complete, please verify 
the pump has resumed.

CAUTION: Do not use the pump remote when the pump is being read. 

If the pump battery is low, the pump will not send data to the PC. Replace the battery if 
the device status screen indicates battery power is low.    

2 Verify that the data in the Choose port field is correct for this 

device. 

To change this setting, click the arrow for the field and select a 

different setting.

Read Device bar

READ DEVICE button
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3 Make sure the device is connected to your computer. 

4 If the device is a pump, you can specify how much data to get from 

it. Click the Amount of Data arrow and select an amount.

NOTE: If you select All
available data, the

system reads all data
in the pump. This

overwrites any existing
duplicate data in the

system.

5 Click READ DEVICE. Be sure to read the message that is displayed 

carefully because it provides specific instructions for reading the 

pump.

6 Follow the instructions and click OK. 

The read device progress bar is displayed.

You can choose to cancel the read at any time by clicking CANCEL.

A message is displayed to confirm that the read is complete.

7 Click OK.

Device data should now overlap with the reporting period.

8 Click NEXT at the top of the Reports workspace.

The Verify Report Settings step is displayed. This allows you to make 

sure the settings for this patient are correct before you run the 

report(s).

timeline

meal period 

fields for editing meal periods

bedtime and wakeup periods
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Verifying report settings           

1 Make sure the Glucose Target settings are correct. Type the correct 

values, or click the up or down arrows in the Low and High fields to 

raise or lower values.

NOTE: You can have as
many as five meal

periods. The defaults
are breakfast, lunch

and dinner.

2 To add a new meal period to the Meal Settings, click ADD MEAL. To 

edit an existing meal period, click anywhere within one of the meal 

periods along the timeline.

The Meal Period editor becomes active.

3 Enter text or click arrows to select the settings you want.

NOTE: If you only want
to use these settings for
this meal, de-select the

check box next to Use
these parameters for all
of this patient’s meals.

– Meal Name: name you want to assign to the meal period.

– Meal Time Period: hours between which the meal occurs.

– Pre-Meal BG Target (mg/dL or mmol/L): low and high ends of the 
patient’s before-meal glucose target range.

– Pre-Meal Analysis Period: how much time before the start of the 
meal will glucose be analyzed for the report. The meter readings 
captured during this time are used in detailed report analysis.

– Post-Meal BG Target (mg/dL or mmol/L): low and high ends of 
the patient’s post-meal glucose target range.

– Post-Meal Analysis Period: how much time after a meal will 
glucose be analyzed for the report. The meter readings captured 
during this time are used in detailed report analysis.

NOTE: Meal periods
cannot overlap, but

start and end lines can
border one another.

Meal periods must be at
least 60 minutes in

length.

You can change the length of an existing meal period or wakeup and 

bedtime period by clicking on the start or end handles, and dragging 

and dropping them along the timeline. 
 

select the start or end handle, and drag and drop it along the timeline

timeline

meter reading markers
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4 To use the settings from this meal for all of the patient’s other 

meals, make sure the check box next to Use these parameters for all 

of this patient’s meals is selected.

5 After you finish creating or editing a meal period, click SAVE.

6 To remove a meal period, click DELETE MEAL. Click DELETE when 

asked to confirm.

7 CareLink Pro can remember these settings for this patient the next 

time you run a report for them. To save them for this patient, click 

SAVE SETTINGS.

8 Click NEXT at the top of the Reports workspace. 

This is the Select and Generate Reports step of the process. It 

provides a list of report types as well as a Data Table that helps you 

choose to include or exclude certain days of data from the Daily 

Detail report(s). 

NOTE: To modify the
Data Table display,

click >>customize
columns. See Report

Generation preferences,
on page 22.

Selecting report types and inclusion dates           

1 Select the check box next to the report(s) you want to include in the 

report set.

2 If data has been read from a pump or Guardian monitor more than 

once during this reporting period, there may be multiple device 

snapshots: 

a. Make sure the check box is selected next to Device Settings 
Snapshot. 

Data Table
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b. Click the drop-down arrow and select a snapshot date and time.

– Pumps: Select a snapshot from the patient’s pump.

– Guardian: Select a snapshot from the patient’s Guardian 
monitor.

If either field is dimmed, there are no snapshots available during the 

reporting period.

3 Scroll though the Data Table to review the available Daily Detail 

report information. 

– You can sort the data in each column. Click the column heading 
to sort the data in ascending order. Click the heading again to sort 
the data in descending order.

NOTE: If there is no
data for a certain date,

that date cannot be
selected.

4 Select the check box in the Data Table rows for any date for which 

you want a Daily Detail report. 

– To include or exclude all Daily Detail report dates with one click, 
select the check box at the top of the Data Table check box 
column.

Generating reports                                  

1 After you verify your report selections, click GENERATE REPORTS at 

the top of the Reports workspace

A list of options is displayed.

2 Select an option to preview, print, or save the report(s).

If you selected Preview, the Preview window is displayed.

3 Click the arrow buttons to navigate through multi-page reports.

4 Click one of the other buttons at the top of the Preview window to 

save or print the report(s).

5 To close this window, click the CLOSE button in the upper right 

corner of the window.CLOSE PREVIEW
button
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About reports         

This section provides a description of each report. More details about 

the report components, as well as sample reports are contained in the 

Report Reference Guide. You can access the Report Reference Guide 

through the CareLink Pro software:

1 Help > View Report Reference Guide (PDF). 

2 Select a language for the Report Reference Guide.

The CareLink Pro reports share these common elements:

NOTE: If the reporting
period is longer than 14

days, the report will
have multiple pages.

• Report header — The report header contains identifying information, 

such as the name of the report, the patient's name, and the source of 

the data.

• Carbohydrates and blood glucose levels — Within the graphs and 

charts, carbohydrate units are displayed in italics and blood glucose 

levels are displayed in bold.

• Weekend data — Weekend days are in bold so you can easily identify 

them.

• Legends — A legend of symbols appears at the bottom of each report. 

While a symbol may be used in multiple reports, the legends are 

unique to each report.

Adherence Report        

This report presents data that describes how insulin pumps and 

sensors are used and the patient’s behavior relevant to their therapy. 

It answers the question, “Was there enough data to provide an 

accurate picture of how the patient uses their insulin pump and 

sensor, if applicable” It also answers the question, “Do patients 

adhere to the therapy as instructed?” It also indicates whether you 

may need to speak to your patient about the way they are managing 

their diabetes.

Sensor and Meter Overview Report        

The Sensor and Meter Overview Report provides a graphical 

representation of the patient's daily meter-derived glucose levels and 

averages, including hourly breakdowns over 24 hours and as they 

relate to their meals and sleep patterns. Statistics on the patient's 

glucose readings and insulin usage are also included. 
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A similar analysis of sensor data is generated as the first page of this 

report if sensor data is available. When no sensor data is available, 

the meter data analysis page will be generated as the first page.

The final page(s) of the report shows the day-to-day level and quality 

of your patient’s glycemic, carbohydrate, and insulin control. Each 

page shows how that control varies during each day across the entire 

reporting period up to a 14 day maximum per page.

Logbook Report        

The Logbook report provides meter glucose, carbohydrate, and insulin 

data for each day in the reporting period. It provides a diary of events 

recorded hourly, as well as daily averages and totals. Each page 

contains up to 14 days. If the reporting period exceeds 14 days, extra 

pages are generated.

Device Settings Snapshot        

This report presents a snapshot of the settings for the patient's pump 

or Guardian REAL-Time monitor for a specific date and time. This can 

help you understand other reports or can simply document your 

patients' settings. 

The pump or monitor settings are recorded only when the device is 

read. If the device was not read during the reporting period, no 

settings will be available.

Daily Detail Report        

The Daily Detail report shows glucose data, carb amounts, and the 

patient’s insulin usage for the selected day. A separate report is 

generated for each day you select from the Data Table.

The Daily Detail report provides a detailed look at each day you 

select. It allows you to focus on a particular day if you feel something 

of interest to the patient’s therapy was occurring.

Exporting data          

You can export device data that is acquired and stored by CareLink 

Pro. This gives you all of a patient’s device data to use for statistics 

or the creation of specialized reports or charts. The .csv file can be 
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imported into Microsoft Excel or certain clinical statistics programs 

where you can further manipulate the data.

The .csv file contains data recording the actions of the device. For 

example, it lists the recording of meter readings, the pump receiving 

the meter reading value, or change in basal rate.

NOTE: This is an
advanced feature, and

requires you to be
familiar with the raw

device data. It also
requires proficiency

with any software into
which you import the

.csv file.

Follow these steps to use the CareLink Pro export feature:

1 Click the patient’s tab. Or, click the Open Patient button and double 

click their name.

2 Make sure the Reports workspace is displayed.

3 Use the Duration or From/Through fields to set the dates and length 

of the report.

The maximum duration you can select is 12 weeks.

4 Click the export selected data link.

The Export Data to CSV File dialog box is displayed.

5 To change where you store the .csv file on your computer, click the 

arrow to the right of the Save in field and select a location.

6 If you want to change the name of the file, type it into the File name 

box.

7 Click SAVE.

NOTE: For more
information about the
data displayed in CSV
files, see CSV data, on

page 67.

The .csv file is now saved on your computer in the location you 

selected. You can now choose to import it into any program that 

supports this file type.

export selected 
data link
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System administration 8

What’s in this chapter
• Before you begin: page 57

• Applying software updates: page 58

• Backing up and restoring the database: page 59

It is important that you regularly back up the CareLink™ Pro 

database. The database stores all system data that has 

accumulated in your patient’s records, including profile 

information, device-derived data, and report settings. 

CareLink Pro lets you save copies of the database and restore 

them.

It is also important that you have the latest version of CareLink 

Pro. Updated versions are available periodically, and may contain 

important enhancements. You can choose to search for updates or 

to be notified when they are available.

Before you begin

It is a good idea to establish a regular schedule by which to perform 

database backups. This will help ensure that it is done regularly, and 

will minimize the risk of data loss. 

During backup or restore, CareLink Pro detects other users who 

may be using the software on other computers, and offers them a 

chance to save their work. However, it is still good practice to 

check for other users before starting either process.
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Applying software updates            

Automatically receiving updates

There will be occasional updates to the CareLink Pro software. When 

notice of an update is displayed, take the following steps to download 

the latest software release.

NOTE: The database
should be backed up

before a software
update is applied. See
Backing up a database,

on page 59.

1 Make sure an Internet connection is available and active on your 

computer.

2 The CareLink Pro Update message is displayed when there is an 

update to CareLink Pro. It gives you the option to download the 

update.

3 Click DOWNLOAD. (If you click CANCEL, the update notice will close. 

You can download the update at a later time.)

A warning message is displayed that recommends backing up your 

database.

4 Click YES to create a backup of your database (see Backing up a 

database, on page 59 for this procedure). Click NO if you do not 

choose to back up your data.

A message will display to confirm that the new version of CareLink 

Pro has been downloaded.

5 To begin using the latest version of CareLink Pro, click YES to close 

and re-open the software application. Click NO if you would prefer 

to wait before re-starting CareLink Pro.

Turning off automatic updates

If you do not want to receive automatic notification of CareLink Pro 

updates, follow these steps:

1 Select Tools > Options.

2 Click the General tab.

3 Under the Communications section, clear the check box next to 

Automatically check for software updates.
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Manually checking for updates

You can manually check for CareLink Pro updates at any time.

NOTE: The database
should be backed up

before a software
update is applied. See
Backing up a database,

on page 59.

1 Make sure an Internet connection is available and active on your 

computer.

2 Select Tools > Check for Software Updates

3 You will receive a message if no updates are currently available. If 

an update is available, a CareLink Pro Update message is displayed. 

4 Follow the procedure in Automatically receiving updates, on 

page 58.

Backing up and restoring the database

Backing up a database     

The following steps let you back up the current database to the 

location you select.

1 Make sure all patient records are closed.

2 Select Tools > Backup Database.

NOTE: Database
backups can be saved

on a network drive, or
to removable storage
(DVD, CD, USB drive,

etc.).

3 To save the backup to a different location on your computer, click 

the arrow on the right of the Save in field and select a new location.

4 If you want to change the name of the backup file, type it into the 

File name box.

5 Click SAVE. A progress bar is displayed while the database is saved.

A message is displayed when the backup is complete.

6 Click OK to close the message.

Restoring a database         

The current database may need to be replaced if it can no longer be 

accessed or used. The more current your backup, the less data you 

will lose if you replace the database.

CAUTION: Before you restore, make sure the existing database is no longer useful. When 
you restore with a backup copy, you lose all the new data created since the selected 
backup copy was made.

The following steps let you select a backup copy to replace the 

current database.

1 Make sure all patient records are closed.
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2 Select Tools > Restore Database. 

3 Use the Look in field to select the location from which to copy the 

backup database.

4 Select the backup file you want to use to replace the current 

database (usually the most recent).

5 Click OPEN. A warning message is displayed to remind you about the 

data that may be lost if you continue the database restore.

6 To continue, click OK. A progress bar is displayed while the database 

is being restored.

A message is displayed when the database is restored. 

7 Click OK to close the message.

Locking the database                 

If you are backing up or restoring the database, you will be alerted if 

there are active users of the software on other computers. You will 

be prompted to begin a procedure to temporarily lock the database.

1 If there are other people using the software when you start a backup 

or restore, a message is displayed to notify you of this.

2 Do one of the following:

– Select YES to temporarily lock the database. Each active user will 
receive a lockout notification, alerting them that the software 
will shut down in 20 seconds, and that they should save their 
work. If another user cancels the lockout procedure, the software 
will notify you. In this case, click OK and try again later.

– Select NO to stop the lockout procedure and allow other active 
users to continue.

Responding to a database lockout notice                  

1 If another user is attempting a database backup or restore while you 

are using the software, a message is displayed notifying you of the 

impending backup.

2 Do one of the following:

– Click OK to allow the interruption. 

– Select CANCEL to stop the application from shutting down. This 
allows you to complete your current task. 
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When the system is unavailable                

If you attempt to use the system, you may receive a message 

notifying you that the system is not available. This means that 

another user is already in the process of backing up or restoring the 

database. No other users can access the system until the task is 

complete.

Do one of the following:

• Wait for the process to complete and for the system to become 

available.

• Click CANCEL to exit and try again later.
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Troubleshooting 9

What’s in this chapter
• General application use errors: page 62

• Device read errors: page 63

• Report creation errors: page 64

• Backup and restore errors: page 65

• Uninstalling the software: page 65

This chapter is designed to help you solve issues that may occur 

while using CareLink™ Pro software. It also contains instructions 

for uninstalling the CareLink Pro software if the need for that 

should arise.

General application use errors

Privileges to download software upgrades over the Internet

If you try to download a software upgrade over the Internet, you 

may receive the message that you do not have sufficient privileges 

to do so. You must have administrative privileges to download 

CareLink Pro software upgrades.

1 Close the CareLink Pro software application, and restart your 

computer system. 

2 Have someone with administrative privileges log in to the 

computer.

3 Follow the instructions in Applying software updates, on 

page 58.
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Not connected to the database

An error message stating that you are not connected to the database 

indicates one of the following:

• The database has been moved. The database must be located in the 

same place that was selected during installation of the CareLink Pro 

software. If it has been moved, it must be moved back to the location 

selected during installation.

• You are not connected to the network drive where the database is 

located. If the database is located on a network drive, the network 

may occasionally experience problems that prevent you from 

accessing the drive. Contact your computer support department for 

help in reconnecting to the network drive where the database is 

located. 

Forgot the clinic password for CareLink Pro

If no one can remember the password your clinic uses to log in to 

CareLink Pro, the only solution is for the CareLink Pro software to be 

re-installed, and a new database created.

Device read errors

Read Device Error Explanation

The selected serial port 
could not be opened. 
Another operation might be 
in progress on that port. 
Please wait until the port is 
available, or select another 
port.

Please verify that the com port selected is not in 
use by another program, or select a different 
port. Try rebooting the computer you are using 
and then try the device read again. The hardware 
(cable, etc.) connected to the port or the port 
itself may be bad. Connect the hardware to 
another port and try the device read again to 
help determine the problem. 

Auto Detect could not find 
the device on any available 
port. Please check the cable 
connection, device battery & 
status and try again, or try 
specifying a serial port.

Check the connection between the cable and the 
PC, and verify that the device battery status is 
fine. If so, try specifying the PC serial port to 
which the cable is connected, rather than 
selecting Auto Detect.

Device not found at selected 
serial port. Please check the 
cable connection, device 
battery & status and try 
again, try selecting a 
different port, or try to Auto 
Detect the device.

Check the connection between the cable and the 
PC, and verify that the device battery status is 
fine. If so, try either selecting a different PC 
serial port number, or choose the Auto Detect 
option.
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Report creation errors

Multiple data entries for the same date

If multiple data entries exist for the same date and time for the same 

device, the system considers this to be a conflict that it cannot 

resolve. Reports created using this device data will omit the portion 

of data that overlaps. 

You can try to adjust the reporting period to miss the overlapping 

data. Or, you can remove the device from the system and then add it 

back again to clear the previous readings.

Unable to communicate with 
the device. Please ensure 
you’ve attached and 
selected the correct device, 
check the cable connection, 
device battery and status, 
and try again.

Verify all settings selected for the device read, 
including device name, serial number and type of 
connection. Also check to make sure that the 
device, cable and PC are connected properly. 
Verify the battery and alarm status of the device 
is okay. Try the read again.

Unexpected response... 
retrying (n%)

An unexpected value was read from the device. 
The system retries communication until you 
cancel or communication succeeds.

The communication device 
was found, but the pump 
(<serial #>) is not 
responding. Please verify the 
pump’s serial number, place 
the pump closer to the 
communication device to 
minimize interference, 
check pump battery and 
status.

Verify that the correct pump serial number was 
entered. If not, re-enter the correct serial 
number. If the serial number is correct, try 
moving the pump closer to the communication 
device, or locating the communication device and 
pump away from possible interference (such as 
other RF devices), or checking the pump battery 
and delivery status.

This pump is delivering a 
temp basal. Please cancel 
the temp basal or wait until 
it completes, and then try 
again.

The pump you are attempting to read is 
delivering a Temp basal. Either wait until the 
Temp basal completes to read the pump, or 
cancel the Temp basal and then read the pump.

This pump has active errors 
or alarms. Please clear the 
alarms and try again.

There are active alarms on the pump which 
prevent it from being read. Read the alarm 
instructions for clearing the alarm. Clear the 
alarm and try the pump read again.

This pump is delivering a 
bolus. Please cancel the 
bolus or wait until it 
completes, and then try 
again.

The pump you are attempting to read is 
delivering a bolus. Either wait until the bolus 
completes to read the pump, or cancel the bolus 
and then read the pump.

The device returned invalid 
entries; all data read will be 
discarded.

Contact the 24 Hour HelpLine or your local 
country representative (see Assistance, on 
page 3). 

Read Device Error Explanation
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System is going to ignore data

If the time on a device has been changed causing overlaps or gaps in 

data of three hours or longer, the system does not include that 

portion of data when creating reports.

Backup and restore errors

The database cannot be locked

This means that you are using the system in a multi-user environment, 

and other users are logged in. The system will not allow a database 

backup to be performed while other users are potentially performing 

tasks that may affect the database. Once all other users exit CareLink 

Pro, you can perform the database backup.

A database backup or restore is not completing

Other users cannot log in and the backup or restore cannot complete. 

Please contact the helpline or your local country representative (see 

Assistance, on page 3).

A restore database fails

The database backup file you are attempting to use in the restore 

process is corrupt. Try restoring with a different backup file.

Uninstalling the software

If you need to uninstall CareLink Pro, take the following steps:

1 Open the Control Panel through your Windows Start menu.

2 Select Add or Remove Programs.The Windows Add or Remove 

Programs window is displayed.

3 Scroll down to Medtronic Carelink Pro and click on it.

4 Click REMOVE. The InstallShield Wizard is displayed.

5 Click NEXT. A message is displayed asking you to confirm that you 

want to remove the application.

6 Click YES. The uninstall program runs and removes the program and 

all of its files from your computer. When it is done, a message 

displays on the wizard screen confirming the uninstall.

7 Click FINISH.



CareLink Pro™ User Guide          66

Icon table
The icons and symbols on the packaging labels and the equipment are 

described in the following table:

Description Icon

One Per Container/Package (1x) 

Attention: See Instructions for Use

CD enclosed

Important documents enclosed

Catalogue number REF

CE mark by notified body as a medical 
device
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CSV data A

This appendix defines the columns of the CareLink™ Pro data that 

you see when you export to CSV format. It also provides other 

information you may need to know about CSV files. 

NOTE: All data is what
was recorded in the
device at the listed

date and time.

Column data definitions

Consult this table to better understand the type of data in each 

column.

Column heading Definition

Index The order in which data was recorded in the 
device.

Date The date data was recorded in the device.

Time The time data was recorded in the device.

New Device Time The new date and time if this was changed in the 
device.

BG Reading (mg/dL or 
mmol/L)

The blood glucose reading recorded by the meter 
or pump. If the data is from a pump, this column 
reflects manual BG’s and BG’s received from a 
Link meter. 

Linked BG Meter ID The serial number for the meter that sends blood 
glucose readings to the device.

Basal Rate (U/h) The active basal insulin delivery rate in units per 
hour.

Temp Basal Amount 
If a temp basal was applied on the pump, this 
value is the amount (new insulin rate or percent 
of basal). 

Temp Basal Type The setting for temporary basal delivery type 
(insulin rate or percent of basal).

Temp Basal Duration (m or%)
The length of time in minutes or percentage for 
the temporary basal insulin delivery (see type 
above).
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Bolus Type The bolus insulin delivery type [Normal, Square, 
Dual (normal part), or Dual (square part)].

Bolus Volume Selected (U) The number of units of insulin selected to be 
delivered during the bolus insulin delivery.

Bolus Volume Delivered (U) The number of insulin units actually delivered 
during the bolus insulin delivery.

Extended Bolus Duration (h) Duration of the square portion of either a square 
bolus or a dual wave bolus.

Prime Type

The prime type—manual or fixed. Manual is used 
just after a rewind, to fill the infusion set tubing 
with insulin before inserting it. Fixed is used after 
infusion set insertion to fill the soft cannula with 
insulin after removing the introducer needle.

Prime Volume Delivered (U) The number of units of insulin actually delivered 
for the prime.

Alarm The name of the alarm that occurred.

Suspend States “Suspended” when the pump is suspended, 
and “Resumed” when the pump is resumed.

Rewind Rewind event at the date and time of the device 
read.

BWZ Estimate (U) The bolus insulin estimate if calculated with the 
Bolus Wizard feature on the Paradigm pump.

BWZ Target High BG (mg/dL 
or mmol/L)

The Paradigm pump setting for the high end of 
the blood glucose target range, set through the 
Bolus Wizard feature.

BWZ Target Low BG (mg/dL 
or mmol/L)

The Paradigm pump setting for the low end of the 
the blood glucose target range, set through the 
Bolus Wizard feature.

BWZ Carb Ratio

The Paradigm pump setting for insulin-to-
carbohydrate ratio. If grams are used as the 
units, the ratio is the number of grams covered by 
one unit of insulin. If exchanges are used for 
units, the ratio is the number of insulin units 
needed to cover one exchange. This is set through 
the Bolus Wizard feature.

BWZ Insulin Sensitivity

The Paradigm pump setting for insulin sensitivity. 
Insulin sensitivity is the amount the blood glucose 
level is reduced by one unit of insulin. This is set 
through the Bolus Wizard feature.

BWZ Carb Input
The input for expected amount of carbohydrate 
consumption when using the Bolus Wizard feature 
on the Paradigm pump to estimate a bolus.

BWZ BG Input (mg/dL or 
mmol/L)

The input for meter blood glucose reading when 
using the Bolus Wizard feature on the Paradigm 
pump to estimate a bolus.

BWZ Correction Estimate (U)
The estimated units of bolus insulin to give for 
blood glucose level correction, as calculated 
throughout the Bolus Wizard feature.

BWZ Food Estimate (U)

The estimated units of bolus insulin to give to 
cover the expected amount of carbohydrate 
consumption, as calculated through the Bolus 
Wizard feature.

Column heading Definition
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More about CSV files

The title at the top of CSV file includes the following:

• patient’s name

• a list of selected devices and their serial numbers

• selected date range

Each block of columns has a title that includes the following:

• name of the device to which the block of data applies

• serial number of that device 

If data is not displaying as expected

There are a number of different factors that can cause the CSV data 

to display differently than expected. A few of these factors are listed 

below:

• Date or time changes on the device can either change the sequence 

or cause records outside the selected date range to display.

• If there is a large gap between device reads, data for that device may 

be displayed in multiple blocks.

BWZ Active Insulin (U)

The amount of active insulin calculated to be left 
in the body from prior bolus insulin deliveries 
when determining the estimated bolus amount 
through the Bolus Wizard feature.

Sensor Calibration BG 
(mg/dL or mmol/L)

The BG value used for calibrating the sensor in 
mg/dL or mmol/L).

Sensor Glucose (mg/dL or 
mmol/L) The calibrated sensor glucose value.

ISIG value The ISIG value read from the pump.

Column heading Definition
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Glossary

A
A1c   Glycosylated hemoglobin

A1c Test  Hemoglobin A1c test, used to interpret blood glucose level 
over a period of time.

Area Under the Curve (AUC)  Indicates the amount in high and low 
excursions as determined by preset values. Excursion data indicates 
the frequency of highs or lows. AUC indicates the magnitude of events 
by showing how far out of range and for how long.

Audio bolus  The pump can be programmed so the user hears a beep 
when they select a bolus insulin amount (0.5 or 1.0 units) to be 
delivered. This is useful for situations when it is difficult to see the 
buttons on the pump.

B
Basal insulin  An hourly, continuous infusion of insulin delivered 
automatically by an insulin pump based on preprogrammed profiles 
and personalized rates set in the pump. The pump delivers a daily 
infusion of insulin that typically covers "background" insulin needs 
during periods of fasting (i.e., overnight and between meals).

Basal patterns  The user can program up to three different basal rate 
patterns into their pump for the delivery of basal insulin: Standard, 
A, and B. For each pattern there is the option of setting up to 48 
basal rates.

Basal profile  A basal rate with a start and stop time. The user can 
program several different profiles into their pump, each with a 
different basal rate, during a 24-hour period of time to achieve better 
glucose control.

Basal rate  The pump setting that provides a continuous infusion of 
insulin to keep the blood glucose stable between meals and during 
the night. Basal insulin mimics pancreatic insulin delivery—which 
meets all the body’s non-food related insulin needs.

BG  Blood Glucose
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Bolus insulin  A dose of insulin given to cover an expected rise in 
blood glucose (such as the rise after a meal or a snack) or to lower a 
high blood glucose down to target range.

C
Cal Reminder   The pump will trigger a Meter BG By HH:MM alarm 
automatically every 12 hours, signaling that the current calibration 
value is no longer valid. The value of the Cal Reminder is the amount 
of time before the current calibration value expires by which the user 
wants to be reminded to calibrate. For example, if the Cal Reminder 
is set to 2 hours, the Meter BG By HH:MM alarm will occur 2 hours 
before calibration is required.

Carb ratio (carbohydrate ratio)  The amount of carbohydrates 
covered by one unit of insulin. (Also see exch ratio.)

Carb units  The food entry when using the Bolus Wizard. Entered as 
(carbohydrate) grams or exchanges.

CareLink® Personal  An online service that allows management of 
diabetes data via the Internet.

CH  Carbohydrate

Com-Station  A device used to download MiniMed 508 pump and pass-
through third-party meter data to the computer.

ComLink   A radio frequency (RF) transceiver device used to 
download Paradigm pump data to the computer.

Correction bolus  The amount of insulin needed to return a high 
blood glucose level back down to target range.

Correction bolus factor (Sensitivity factor)  How much 1.0 unit of 
insulin will lower your blood glucose. This factor is used to calculate a 
correction bolus amount when your blood sugar is high.
(BG level) – (BG target) = X. 
X ÷ (correction bolus factor) = 
correction bolus amount

D
Dual Wave® bolus  Combination of a Normal bolus that is delivered 
immediately, then followed by a Square Wave bolus. The Square Wave 
portion is delivered evenly over a period of time.

E
Easy Bolus™  Method of delivery for a Normal bolus by using the Easy 
Bolus button on the pump.

Exch ratio (exchange ratio)  The amount of insulin required to cover 
one (1) carbohydrate exchange. (Also see carb ratio.)

Express bolus  Method of delivery for any bolus type using the 
express bolus button on the pump.
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F
Food bolus  A dose of insulin given to cover the expected rise in 
blood glucose that occurs after eating.

H
HbA1c   Glycosylated hemoglobin

HbA1c Test  Hemoglobin A1c test, used to interpret blood glucose 
control or average of levels over a 2- to 3-month period of time.

High Glucose  The pump will alarm if the sensor indicates that the 
user’s sensor glucose is at or above this value. You have the option to 
turn this feature on or off.

Hyperglycemic  Elevated blood glucose as seen by monitoring blood 
glucose levels with or without any or all of the following symptoms: 
nausea, vomiting, blurred vision, headache, gastric distress, frequent 
urination of large amounts, and lethargy. 

Hypoglycemic  Low blood glucose as seen by monitoring blood 
glucose levels, with or without any or all of the following symptoms: 
excessive hunger, shaking or tremors, perspiration, "dancing" visions, 
light-headedness, headache, blurred speech, sudden mood swings or 
personality change.

I
Infusion set  The apparatus used for inserting and securing a cannula 
below the skin and transporting insulin to the insertion site via tubing 
from the pump.

Insulin concentration  The strength or type of insulin the doctor has 
prescribed for the user. This affects the rate of insulin the pump 
delivers. If the user’s insulin concentration changes, the basal 
patterns and the maximum basal and bolus rates must be 
reprogrammed in the pump.

Insulin sensitivity  The amount of mg/dL (or mmol/L) that your blood 
glucose (BG) level is reduced by one unit of insulin. (Bolus Wizard 
data.)

ISIG  Sensor values that indicate whether the transmitter electronics 
in a sensor-augmented system are working properly. If you see an ISIG 
value that is less than 24.00 nA or more than 29.00 nA, call for 
product assistance. It may be time to replace your transmitter. 

K
Ketone test  Ketone is a waste product that is produced when the 
body is forced to burn body fat instead of glucose for energy. It may 
be a sign of lack of insulin in the body. The Ketone test measures the 
amount of ketone concentrated in the blood or urine.
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L
Link  To turn on and setup the meter option that allows the pump to 
receive BG readings from the Paradigm Link meter.

It is also used in this system to refer to hypertext links. When clicked 
on, hypertext links take you to another place in the system or to 
another Web site.

Low Glucose  The pump will alarm if the sensor indicates that the 
user’s sensor glucose is at or below this value. You have the option to 
turn this feature on or off.

Low reservoir warning  Programmable warning that notifies you with 
an alert when either a specified number of units remain in the 
reservoir of your pump, or a specified amount of time remains before 
the reservoir will be empty.

M
Manual bolus  Optional item available in the BOLUS MENU when the 
Bolus Wizard is active. One method of programming a bolus without 
the Bolus Wizard. 

Max basal insulin  The maximum amount of basal insulin that the 
pump will deliver at one time. (Set by the user).

Max bolus  The maximum amount of bolus insulin that the pump will 
deliver at one time. (Set by the user).

Mean Absolute Difference (MAD)  Represents the level of accuracy in 
calibration of the sensor to meter readings. The lower this number, 
the greater the calibration accuracy. MAD is calculated by taking the 
difference between closely occurring pairs of SG and meter readings, 
dividing by the meter reading and then averaging across all pairs.

Meter  a medical device for determining the approximate 
concentration of glucose in the blood. A small drop of blood is placed 
on a disposable test strip, which the meter reads and uses to 
calculate the blood glucose level. The meter then displays the level 
in mg/dL or mmol/L.   
Meter option  Feature that allows the pump to receive BG readings 
from a linked BG meter.

N
Normal bolus  An immediate delivery of a specified unit amount of 
insulin. 
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P
Pattern feature  Extended pump feature that allows you to program 
optional basals (Pattern A, Pattern B) that support activities or 
glucose patterns that are not a part of your day-to-day routine, but 
are usual in your lifestyle. Such activities could be a sport that you do 
once a week, a change in your sleep pattern over the weekend, or 
hormonal changes during a menstrual cycle. 

Pattern, standard  Your normal basal that supports your usual day-to-
day activity. When the Patterns feature is off, the pump uses your 
standard (basal) pattern.

R
RF  Radio frequency (RF). 

S
Square Wave® bolus  Bolus delivered evenly over a specified time 
period (30 minutes to 8 hours). 

Square Wave portion  (Sq) The second part of a Dual Wave bolus. The 
Square Wave portion delivers evenly over a period of time after the 
NOW portion delivers.

Step  Measurement of insulin that you set and use for Easy Bolus 
delivery.

Suspend  Function on the pump that stops all insulin delivery. Any 
current bolus and/or prime deliveries are canceled. The basal 
delivery is paused until restarted. 

T
Temp  Temporary

Temp basal (tmp basal)  Temporary one-time basal insulin with a 
specified amount and duration. Used to support insulin needs for 
special activities or conditions that are not part of the normal daily 
routine.

Transmtr ID   The serial number of the transmitter currently in use.

U
μL  micro liter  
Upload  The process for transferring pump or meter data to the 
CareLink™ Personal server.
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